Author Topic: OenGL terribly slow on Geforce 7025  (Read 5661 times)

0 Members and 1 Guest are viewing this topic.


  • Associate
  • Posts: 1
OenGL terribly slow on Geforce 7025
« on: August 03, 2008, 03:19:56 PM »
Hello everyone

I am developing a simulation software on my PC which has a Geforce 7025/Nforce630a chip set (on board) and I am getting terrible speed.

OpenGL is terribly slow (while DirectX is very fast and I do not have any problem playing Sims, Simcity4, Simcity Societies,...) on this PC.

I get an average of 1 frame/second on benchmark program.

Does OpenGL on my PC use the hardware acceleration at all? I have installed drivers of the card (which should normally install the OpenGL also).

What could be wrong?



  • Consigliere
  • ****
  • Posts: 619
Re: OenGL terribly slow on Geforce 7025
« Reply #1 on: August 04, 2008, 04:16:43 PM »
At first try the "Fur render demo" in GPUCapsViewer, it should show a similar framerate (at same resolution).

You can check if OpenGL hardware acceleration is enabled e.g. with glview
Systeminfo: CPU-Z - GPU-Z - GPUCapsViewer


  • Global Moderator
  • Capo Crimine
  • *****
  • Posts: 2385
    • oZone3D.Net
Re: OenGL terribly slow on Geforce 7025
« Reply #2 on: August 04, 2008, 08:05:19 PM »
don't panic, your score is totaly normal for a GPU that has 2 pixel pipelines and 1 vertex pipeline. Recall that FurMark is a very demanding benchmark so level entry graphics cards have low score. Your graphics card is integrated, isn't it?

OpenGL is correctly installated because FurMark doesn't start if the OpenGL 2.0 support is not present. If you have a little time, try to post a screenshot of the first tab of GPU Caps Viewer. The OpenGL version supported by your system is displayed.