Author Topic: Perf GeForce FX 5700LE  (Read 5265 times)

0 Members and 1 Guest are viewing this topic.

Heptaeon

  • Associate
  • Posts: 1
Perf GeForce FX 5700LE
« on: July 15, 2008, 08:15:31 AM »
Voilà, j'ai une GeForce FX 5700 LE 256Mo AGP 8x

J'ai fait un test de rendu d'un bête trapèze (qui est plutôt un rectangle vu le nombre de vertices) qui a 100 000 vertices et j'ai que 30fps.

Ca passe Via VBO pour faire moderne, un vertex shader minimal (1 ligne dans le main), et un pixel shader (ligne aussi) histoire d'avoir une couleur.

J'utilise OpenTK pour voir un peu les perf de la chose. Malheureusement son full screen est un faux full screen. donc autant dire que je suis en fenêtré. Je n'ai rien activer de plus, mes drivers sont à jours et je n'ai pas d"erreur openGL. Et je compile bien en release (même si ça n'y change rien).

Je remplis bien mon buffer en GL_STATIC_DRAW, mais je peu mettre n'importe quel mode mes perfs ne change pas d'un poil. A croire que ma carte ne le prend pas en compte.

Voilà pour finir je me demandais si c'était un peu pareil avec toute les cartes. est ce que entre les valeur annoncer par nvidia (200 million de vertices seconde) et la pratique (3 millions) il y avais toujours une si grosse différence.

Maintenant j'ai peut-être raté un truc car que je fasse GL_STATIC_DRAW ou GL_STREAM_DRAW ça n'y change rien...
j'espérais au moins 10 fois plus même pour du fenêtré en faite.

de votre coté c'est quoi votre feed back ?

Steph3D

  • Capo Regime
  • ***
  • Posts: 399
Re: Perf GeForce FX 5700LE
« Reply #1 on: July 15, 2008, 06:25:26 PM »
En tout cas, si tu essayes avec Demoniak, quant t'actives le VBO sur un mesh static, ça va bien plus vite, enfin sur ma Geforce 7

http://www.ozone3d.net/tutorials/opengl_vbo_p1.php?lang=1